Skyrim | Forum | Esbern Bug Glitch – Quest Cornered Rat in Ratway Warrens in Skyrim Riften | Operation Reality ™ Gaming
RSS

Esbern Bug Glitch – Quest Cornered Rat in Ratway Warrens in Skyrim Riften (109 posts)

Topic tags: alduin wall, bug, cornered, esbern, progression, rat, ratway, skyrim, warrens
  • Profile picture of Graham Patterson Graham Patterson said 2 years, 11 months ago:

    Has anyone else experienced this progression bug? I’ve gotten to a stage of the Cornered Rat quest where I’m supposed to find Esbern in the Ratway Warrens under Riften (which I have) in order to talk to him but I can’t seem to get him to open up the door to the room he’s holed up in nor does he seem to talk.

    I get conversation action menu but he doesn’t respond it’s really quite bizarre. He just opens the view slit through the door, then closes it and it sounds like he’s opening the door but it never does and there’s no way for me to progress due to this. I presume this is a bug and I’m not just missing something that requires doing before he’ll speak to me and open the door?

    Any help would be great because this is really ruining my game progression. This guy seems pretty important to the story. This is on the PC version by the way with the latest patch.

    Thanks.

  • Profile picture of Justin Leroy Justin Leroy said 2 years, 11 months ago:

    Yes you are correct there is a bug of some sort with the game being able to read the “/The Elder Scrolls V Skyrim/Data/Skyrim – VoicesExtra.bsa” file when it comes to that Esbern character which means it screws a bunch of other stuff up if he’s involved apparently because it can’t find his audio files so it sort of hangs.

    To remedy the bug you need to extract that “Skyrim – VoicesExtra.bsa” file using a BSA Extractor and then place the Esbern sound folder in your “/The Elder Scrolls V Skyrim/Data/” folder. By doing that you’re basically manually recreating the directory path the game is going to look for the audio files in. ie. “/The Elder Scrolls V Skyrim/Data/sound/voice/skyrim.esm/maleuniqueesbern”

    Unfortunately though most BSA extractors seem to require Oblivion to be installed or some even plain just don’t work on Skyrim bsa’s for some reason so if you want just the Esbern sound files without trying to find a working BSA extractor you can grab them here (I just uploaded them for you) so that way you don’t need to bother with any extractors etc.

    DOWNLOAD (sound.rar) – http://www.multiupload.com/P4HR8FKUFS

    Bethesda will likely have this bug fixed in the next patch though, although if you can’t wait and want to play through then just put the extracted “sound” directory into your Skyrim “/Data” directory and you’re good to carry on with all the stuff that involves that Esbern character. :)

  • Profile picture of Graham Patterson Graham Patterson said 2 years, 11 months ago:

    Thank you so much Justin! It worked like a charm!

    I’ve just realized I’m actually going to complete a few quests with this Esbern guy by my side before I return him to Riverwood. This guy is pretty much invincible and his fire balls come in mighty handy. :)

    Thanks again!!

  • Profile picture of Justin Leroy Justin Leroy said 2 years, 11 months ago:

    @graham no problem, I’m glad to hear you got it working.

  • Profile picture of zack zack said 2 years, 11 months ago:

    I have been having the same problems…..kinda.
    I never recieved the “A Cornered Rat” questline after completing the Diplomatic one and escaping the Thalmor place.
    I did indeed talk to Delphine and she mentioned Esbern, who was hiding somewhere in Riften.
    Prior to doing all this, I had already talked to Brynolf and joined with the Thieves Guild.
    But now when I approach Esbern, he will NOT open the door and just keeps telling me to go away and the slide keeps shutting back with no dialouge options.
    I already extracted the voice files as mentioned, but that did not fix my problem.
    Please if you can help, it would be greatly appreciated.

  • Profile picture of Graham Patterson Graham Patterson said 2 years, 11 months ago:

    Did you get the option “I’m looking for an old man hiding in Riften” when talking to Brynolf (or something like that) and then have him actually tell you he’s in the Ratway Warrens before going in?

    If I recall you don’t get the quest by default just for completing the Thalmor Embassy mission but you have to find the Esbern Journal or whatever it’s called in the embassy. I can’t recall to be honest but provided you have the journal it should trigger.

    Otherwise the only thing I can think of is did you extract the sound files to the correct directories? Originally I made the mistake of cutting and pasting all the individual .fuz files straight into the Data directory but that doesn’t work. After rereading the bit that you have to keep them in the sub folders that they come in and then place just the sound into the Data folder with all it sub directories intact, restarted the game and it worked.

    I feel your pain with this bug though, it was a big downer for me until I got it fixed. Now though I’ve still not returned Esbern to the Riverwood as he’s way more powerful than Lydia and the others as a companion and he literally can’t die! I don’t know if that’s a bug or it’s because he’s part of a quest but he never dies even if he goes to like 1% health left and drops to his knees for a while while still being attacked. No one can finish him off. I’ve been completing a bunch of quests and exploring all sorts with him by my side and hardly ever die anymore with this Blades guy covering me. I don’t think you’re necessarily supposed to do that but whatever, I’ll use him to explore some dangerous places until I get bored then I’ll dump him off at Riverwood and finish that quest with Delphine. :)

  • Profile picture of Surefire Surefire said 2 years, 11 months ago:

    Man I was about to throw my fucking computer out the window trying to deal with that Esbern twat! :P

    Initially i patched to the Skryim 1.2 patch after I encountered this wanker but it didn’t do shit but then I remembered we had a Skyrim group and low and behold someone asked it first. Did Bethesda even fix this bug in the 1.2 patch because it would appear not.

    Anyways I got it working with those sound files so cheers gents! Now back to the shit hole of Riften! ;)

  • Profile picture of Sean Santos Sean Santos said 2 years, 10 months ago:

    @justin Dude, I lost hope in continuing the game because of this bug. I rushed to the net and because of you I fixed it. I sign upped here just to say thanks to you and please kindly help me in case of further bugs. Thanks dude.

  • Profile picture of Justin Leroy Justin Leroy said 2 years, 10 months ago:

    @lesoul Not a problem. If you have any further bugs please feel free to make a post and I’m sure someone will be able to help you out. Oh and of course, welcome to the group. :)

  • Profile picture of %s Lukas said 2 years, 10 months ago:

    Thanks for the solution Justin. It worked like a charm!

  • Profile picture of %s Patrick said 2 years, 10 months ago:

    I have a torrented version of Skyrim and I am facing the same problem. I downloaded this and it comes up as a folder in my datafolder “/The Elder Scrolls V Skyrim/Data/Maleuniqueesbern”. I tried to open the door in the game and I still had the same problem. If you could help that would be greatly appreciated.

  • Profile picture of Surefire Surefire said 2 years, 9 months ago:

    @Patrick.Stoia what do you mean it comes up as a folder in your datafolder?

    The correct full path the game will check would be “/The Elder Scrolls V Skyrim/Data/sound/voice/skyrim.esm/maleuniqueesbern” as Justin mentioned in his post. Did you download the sound.rar he posted or did you extract the bsa files manually? I downloaded the sound.rar and when extracted the directory structure was already intact so I just cut and pasted it in from the sound on if I recall (i’d really have to extract the rar to double check but I’m pretty sure).

  • Profile picture of %s Patrick said 2 years, 9 months ago:

    @surefire My version of the game does not have the “sound” section in the data folder. It is just a data folder and no sound option. I extracted it to my data folder and it is just sitting in my data folder. I dont have the “sound” folder in my data folder. That is why I am stuck.

  • Profile picture of Devon Black Devon Black said 2 years, 9 months ago:

    Patrick do you have the razor1911 version or something?

  • Profile picture of %s Patrick said 2 years, 9 months ago:

    @Devon Yeah i believe i do. Is that bad?